logo logo

 Back to main page

The NWNX Community Forum

 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
 
Some new plugins.
Goto page Previous  1, 2, 3, 4  Next
 
Post new topic   Reply to topic    nwnx.org Forum Index -> Linux development
View previous topic :: View next topic  
Author Message
StrawMan



Joined: 22 Feb 2012
Posts: 4

PostPosted: Wed Feb 22, 2012 7:05    Post subject: Reply with quote

Hello.
In attempting to install the pre-compiled version linked below.
I'm receiving the following error on server load:

ERROR: dlopen: ./nwnx_haks.so: ./nwnx_haks.so: undefined symbol: NWN_AppManager

This is because, I'd hazard, I'm not running an nwnx2.so compiled directly against the trunk(I'm guessing at the cause here), but instead the pre-compiled stable binary, available from the downloads area.

Unfortunately, recompiling with all the correct libraries isn't an option, given the restrictions imposed by my hosting.

Has anyone encountered the above error message?
Are there any known work-arounds?
I would love to get this up and running.

Any illumination appreciated.

leo_x wrote:
apologies for the horribly late reply. life, a couple other projects, etc. i just pushed an update to nwnx_haks, I cleaned it up a lot. I also tested it against nwnx2.so built from the main trunk and it worked fine for me, so you shouldn't see any of the segfaults you were seeing. I haven't tried it in production yet. the others still need more work before they work with a nwnx2.so built from the trunk.

you can try this one: http://dl.dropbox.com/u/32687721/nwnx_haks.7z

https://github.com/jd28/nwnx

tc,
leo
Back to top
View user's profile Send private message
leo_x



Joined: 25 Aug 2010
Posts: 75

PostPosted: Thu Feb 23, 2012 12:04    Post subject: Reply with quote

[deleted - out of date]
_________________
the awakening (PW Action)


Last edited by leo_x on Sun Dec 22, 2013 20:01; edited 1 time in total
Back to top
View user's profile Send private message
StrawMan



Joined: 22 Feb 2012
Posts: 4

PostPosted: Sat Feb 25, 2012 8:22    Post subject: Reply with quote

Beautiful.
The effort is appreciated!

Unfortunately, there's a number of other technical hurdles on my side that aren't that easy to overcome.
I'm finding that I can't run NWNx 2.8 because the hosts' version of Linux (RedHat 4.1 by all accounts) and subsequently glibc (2.5) is too bloody old.
(NWNx requires at least 2.7 by all accounts). Switching hosts is not an easy option presently, so I'm considering other avenues.

Is compiling it for glibc 2.5 technically feasible?
Or does the plugin have certain dependencies that require the newer C library?
Back to top
View user's profile Send private message
leo_x



Joined: 25 Aug 2010
Posts: 75

PostPosted: Sat Feb 25, 2012 9:59    Post subject: Reply with quote

[deleted - out of date]
_________________
the awakening (PW Action)


Last edited by leo_x on Sun Dec 22, 2013 20:17; edited 1 time in total
Back to top
View user's profile Send private message
StrawMan



Joined: 22 Feb 2012
Posts: 4

PostPosted: Sat Feb 25, 2012 12:57    Post subject: Reply with quote

Haha.
Ossified is the right word for it.

I'm going to put the idea of switching hosts to the rest of the team.
In the meantime, yeah I thought about going the Virtualbox route.
I'm already familiar with that environment, but I dread setting the whole thing up and then trying to force everything to compile against an older library.

I'm a front-end web/LAMP developer by trade.
C/C++ just makes my head ache.
I have very limited working knowledge of those languages.

Well, thanks again greatly for your help.
Would be immensely beneficial to get a newer version of your plugin running with an updated version of NWNx.

Just have to see what I can do.
Back to top
View user's profile Send private message
Skywing



Joined: 03 Jan 2008
Posts: 321

PostPosted: Tue Feb 28, 2012 3:16    Post subject: Reply with quote

Do not use VirtualBox for NWN1 or NWN2. The timer emulation is busted and will cause the game to behavior erratically (perception failing to work at times, timed events ceasing to function or firing erratically, etc.).

The linux view of VirtualBox about sums up the current state of that particular virtualization project.
Back to top
View user's profile Send private message
elven



Joined: 28 Jul 2006
Posts: 259
Location: Germany

PostPosted: Tue Feb 28, 2012 11:25    Post subject: Reply with quote

You can always compile it yourself; it should link fine against glibc2.5 and old libraries. It may be that you'd have to tweak some include path, but nothing elaborate.
Back to top
View user's profile Send private message
ShaDoOoW



Joined: 20 Aug 2005
Posts: 582

PostPosted: Fri Jul 05, 2013 16:50    Post subject: Reply with quote

Bump, cant find a download for these plugins anymore, they are not included in "official" linux nwnx github repository

anyone still have them?
_________________
Community Patch / NWNX Patch / NWNX Files / NWNX Connect
Back to top
View user's profile Send private message
elven



Joined: 28 Jul 2006
Posts: 259
Location: Germany

PostPosted: Fri Jul 05, 2013 17:05    Post subject: Reply with quote

You'll probably have to check it out from jd28's GH repo and build it yourself.
Back to top
View user's profile Send private message
ShaDoOoW



Joined: 20 Aug 2005
Posts: 582

PostPosted: Fri Jul 05, 2013 18:52    Post subject: Reply with quote

elven wrote:
You'll probably have to check it out from jd28's GH repo and build it yourself.
thanks, i found the repository
_________________
Community Patch / NWNX Patch / NWNX Files / NWNX Connect
Back to top
View user's profile Send private message
leo_x



Joined: 25 Aug 2010
Posts: 75

PostPosted: Fri Jul 05, 2013 19:13    Post subject: Reply with quote

[deleted - see top post]
_________________
the awakening (PW Action)


Last edited by leo_x on Sun Dec 22, 2013 20:24; edited 1 time in total
Back to top
View user's profile Send private message
Ravine



Joined: 26 Jul 2006
Posts: 105

PostPosted: Sat Dec 21, 2013 13:41    Post subject: Reply with quote

Hi,

i can't build the haks plugin, Makefile.in is missing.

thx
Back to top
View user's profile Send private message
Ravine



Joined: 26 Jul 2006
Posts: 105

PostPosted: Sun Dec 22, 2013 19:03    Post subject: Reply with quote

I've tried the linked version (http://dl.dropbox.com/u/32687721/nwnx_haks.7z), but looks like that crashes when i set a hak hidden.

gdb says:

Code:

(gdb) bt
#0  0xb76113e0 in strncpy () from /lib/i386-linux-gnu/i686/cmov/libc.so.6
#1  0xb67f063f in Func_SetHakHidden () from ./nwnx_haks.so
#2  0x00000000 in ?? ()


I'm using the latest core 2.8.
Back to top
View user's profile Send private message
leo_x



Joined: 25 Aug 2010
Posts: 75

PostPosted: Sun Dec 22, 2013 20:09    Post subject: Reply with quote

Heya,

Looks like I didn't check to ensure that the request string parameter was properly formatted in this old version... I re-uploaded a compiled version under the same link -- however, it's built with gcc4.8... so it might not work for you either. If it doesn't crash, but doesn't work check the log file.

I will make a Makefile.in so you can build it yourself. You could also build it with the cmake system now, if you wanted too.

Sorry. I'm going to go back through this thread and delete all the old posts as they are largely outdated.
_________________
the awakening (PW Action)


Last edited by leo_x on Sun Dec 22, 2013 20:13; edited 1 time in total
Back to top
View user's profile Send private message
Ravine



Joined: 26 Jul 2006
Posts: 105

PostPosted: Sun Dec 22, 2013 20:11    Post subject: Reply with quote

Oh thanks, gonna try it now Smile
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    nwnx.org Forum Index -> Linux development All times are GMT + 2 Hours
Goto page Previous  1, 2, 3, 4  Next
Page 3 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group