logo logo

 Back to main page

The NWNX Community Forum

 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
 
Nwnx_leto/Server start problem (FIXED)

 
Post new topic   Reply to topic    nwnx.org Forum Index -> Linux technical support
View previous topic :: View next topic  
Author Message
Savagefool



Joined: 23 Apr 2015
Posts: 6

PostPosted: Fri May 01, 2015 13:19    Post subject: Nwnx_leto/Server start problem (FIXED) Reply with quote

Hello we have a grave error, any help would be greatly appreciated, it's taken us a long time to get to this stage, and this is the last hurdle to overcome.
Okay so currently we have a PRC, CEP mod.

This module runs at about 2-3% load.
As soon as we add nwn_leto pluggin the load hits 100%, at idle..
Does anyone have any info on this? I'm stumped..
It doesn't appear to be any resource or duplicate conflicts, database corruption shouldn't be a problem since it works without the plugin enabled.

Now for some more information from the back-end guy:

Halgroth:
I'll attempt to provide more detail. Any help on the matter would be greatly appreciated.

System specifications
OS: Ubuntu 14.04 x86_64
NWNX: Compiled from sources (github.com/NWNX/nwnx2-linux)
NWNX plugins:
    nwnx_funcsext.so - nwnx_reset.so -
    nwnx2.so - nwnx_funcs.so - nwnx_resman.so -
    nwnx_areas.so - nwnx_functions.so - nwnx_serverlist.so -
    nwnx_chat.so - nwnx_hashset.so - nwnx_spells.so -
    nwnx_connect.so - nwnx_leto.so - nwnx_structs.so -
    nwnx_defenses.so - nwnx_mnx.so - nwnx_system.so -
    nwnx_dmactions.so - nwnx_names.so - nwnx_tmi.so -
    nwnx_events.so - nwnx_odbc.so - nwnx_tweaks.so -
    nwnx_extend.so - nwnx_optimizations.so - nwnx_visibility.so -
    nwnx_fixes.so - nwnx_profiler.so - nwnx_weapons.so

Module haks: PRC3.5, CEP2.4a, Worms tileset

PRC switches:
Default
Library dependencies:
$ ldd nwnx_leto.so
linux-gate.so.1 => (0xf7704000)
libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf76db000)
libstdc++.so.6 => /usr/lib/i386-linux-gnu/libstdc++.so.6 (0xf75f2000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf7443000)
/lib/ld-linux.so.2 (0xf7705000)
libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf73fd000)
libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf73e0000)

$ ldd LetoScript.so
linux-gate.so.1 => (0xf777e000)
libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf76d5000)
libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf76d0000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf7521000)
/lib/ld-linux.so.2 (0xf777f000)

Problem description

Basically what savage said, but I'll elaborate slightly. At first, running server startup script without nwnx_leto.so in serverdir starts the server perfectly and everything runs fine. No errors reported in the logs. However, upon login the following error shows up in nwserverLog.txt:

Error: Letoscript is not setup correctly or it cannot find your bic file. Check nwnx_leto.log for error messages.


The attempted client connection is consequently booted. Thus, even though nwnx_leto may be deprecated by nwnx_funcs, I can only conclude the leto plugin is required by PRC as it's the plugin used in the scripts. Next, when we add leto plugin by placing nwnx_leto.so and LetoScript.so in serverdir, we get the behavior that savage described.

Startup script also contains the line:

export LD_PRELOAD="./nwnx2.so ./LetoScript.so"

stdout:

NWNX2lib: Init
NWNX2lib: org SetString() at 81f41b4, new SetString() at f7723d96
NWNX2lib: org GetObj() at 81f40bc, new GetObj() at f7723dbd
* Parsing configuration...
NWN Extender v2.8-dev
2004 by the APS/NWNX Linux Conversion Group
2007-2010 by virusman and Acaos
Based on the Win32 version 2003 by Ingmar Stieger (Papillon)
and Jeroen Broekhuizen
visit us at http://www.avlis.org


Based on the Win32 version 2003 by Ingmar Stieger (Papillon)
and Jeroen Broekhuizen
visit us at http://www.avlis.org

* Searching for signatures...
* Loading modules...
EVENTS plugin registered.
PROFILER plugin registered.
CHAT plugin registered.
FIXES plugin registered.
AREAS plugin registered.
TMI plugin registered.
SPELLS plugin registered.
TWEAKS plugin registered.
WEAPONS plugin registered.
MNX plugin registered.
OPTIMIZATIONS plugin registered.
RESMAN plugin registered.
FUNCTIONS plugin registered.
SYSTEM plugin registered.
CONNECT plugin registered.
ODBC plugin registered.
HASHSET plugin registered.
SERVERLIST plugin registered.
FUNCS plugin registered.
DEFENSES plugin registered.
NAMES plugin registered.
FUNCSEXT plugin registered.
STRUCTS plugin registered.
LETO plugin registered.
RESET plugin registered.
DMACTIONS plugin registered.
EXTEND plugin registered.
VISIBILITY plugin registered.
* NWNX2 activated.
Neverwinter Nights Server
Build:8109
Copyright BioWare Corp 1998-2004

Server: Loading...
Server: Running...

Server: Loading module "test_server"...Killed


After those three dots I end up sending kill -9 pid since it'll just stay there at 100% forever. Since the module never finishes loading, there is no plugin log output other than

NWNX-Leto Linux module (build 03)
2004 by David Frauzel (dragonsong), dragon@weathersong.net
Information and support: http://weathersong.infopop.cc
* Loading LetoScript.so...
* LetoScript plugin activated.


Any ideas?


Last edited by Savagefool on Fri May 22, 2015 16:42; edited 2 times in total
Back to top
View user's profile Send private message Send e-mail
Lokey



Joined: 02 Jan 2005
Posts: 158

PostPosted: Sun May 03, 2015 6:50    Post subject: Reply with quote

I notice funcs and funcsext, isn't that an either-or?

I messed around, couldn't get leto working with nwnx builds of at least 3 years back (we currently use older, but we've been on dev hiatus for 2 years). Would just fall over in segfault though.
_________________
Neversummer PW NWNx powered mayhem Wink
Back to top
View user's profile Send private message
TemplarDrake



Joined: 10 May 2015
Posts: 1

PostPosted: Mon May 11, 2015 19:54    Post subject: LetoScript.so Reply with quote

Hi guys! I'm also apart of this project. We seem to have fought ourselves through the above error, however a new one has come up.

In the logs we get this error:

* Loading LetoScript.so...
* Failed loading LetoScript.so! ./LetoScript.so: undefined symbol: ScriptDll.so

Any ideas?

- Drake
Back to top
View user's profile Send private message
Savagefool



Joined: 23 Apr 2015
Posts: 6

PostPosted: Tue May 12, 2015 12:00    Post subject: Reply with quote

Lokey wrote:
I notice funcs and funcsext, isn't that an either-or?

I messed around, couldn't get leto working with nwnx builds of at least 3 years back (we currently use older, but we've been on dev hiatus for 2 years). Would just fall over in segfault though.


Removed most of the plugins including those, fixed it without such things happening, seem I was the one creating the fault.. randomly.. somehow.. Um, who is the guy that made nwnx_leto? I could do with getting in touch with him or someone who can do prc/cep servers.
Anyone any ideas what ScriptDLL.so actually is?
Back to top
View user's profile Send private message Send e-mail
Savagefool



Joined: 23 Apr 2015
Posts: 6

PostPosted: Mon May 18, 2015 16:53    Post subject: Reply with quote

TO update, we have gotten rid of Leto and we can now log in. Funcsext appears to be different from funcs though..
In prc the switches need to be set BEFORE the mod load scripts. There is also an error in prc_inc_shifting with a mentions to a phrase called CHUNK_SIZE change this too 25, recompile and place in your custom hak to fix the compile error.
However, funcs is now not working either aha. *facepalm
Back to top
View user's profile Send private message Send e-mail
Savagefool



Joined: 23 Apr 2015
Posts: 6

PostPosted: Mon May 25, 2015 16:01    Post subject: Reply with quote

Update on this for anyone that gets the same problem, everything is working as normal.
Leto was deleted, You need to set bop switches oncliententer BEFORE prc_onenter is called as the scripts are sequential.
Furthermore there is an error in prc_inc_shifting.nss contained within include prc .hak
Make the changes to CHUNK_SIZE from the aforementioned phrase to 25 and that get fixed. Add to custom merge hak that you created in order for cep and prc to work in conjunction with each other.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    nwnx.org Forum Index -> Linux technical support All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group